Installation errors

The SetSeed installer is designed to guide you through configuring your server and installing SetSeed but you might encounter some of the following issues.

System Requirements

Before you install SetSeed on your server you need to make sure your system meets the system requirements.

SetSeed runs on your hosting system, which means you have full control over quality of service. Your server needs to be a Linux based PHP and mySQL installation with Apache (LAMP).

Apache 2 with 'AllowOverride' set to 'All' and the following mods enabled:
mod_rewrite
mod_deflate
mod_setenvif
mod_headers
mod_expires

PHP 5.2+ with working mail() function and extensions:
cURL
mysql
ionCube Loader
GD

mySQL 5.0+

Running the installer

When you download SetSeed and run the installer for the first time you may need to make some changes to your configuration. Below are some of the errors you might receive and more information on how to fix them.

Apache errors

The Apache module 'mod_rewrite' is not enabled on this server.
The Apache module 'mod_deflate' is not enabled on this server.
The Apache module 'mod_setenvif' is not enabled on this server.
The Apache module 'core' is not enabled on this server.
The Apache module 'http_core' is not enabled on this server.
The Apache module 'mod_headers' is not enabled on this server.
The Apache module 'mod_expires' is not enabled on this server.

The way in which you enable Apache modules varies depending on what flavour of Linux you are using. If you are using Ubuntu you can run:

sudo a2enmod rewrite

Where 'rewrite' is the name of the mod you want to enable (without the 'mod_' prefix). If you are using CentOS you can enable modules by uncommenting lines in the httpd.conf file.

After enabling the modules you will need to restart Apache on your website server.

Your server doesn't allow Apache configuration via .htaccess files

If you are on a shared server or don't have access to your apache configuration file please contact your host and ask them to make this change for you.

If you have access to your server you can try making the change yourself.

Please edit your server's VirtualHost configuration file to change the 'AllowOverride' Apache directive to 'All' - it is probably set to 'None' at the moment. For example you will probably have a line in your config file as follows:

AllowOverride None

This needs to be changed to:

AllowOverride All

Once you have made this change, restart Apache and then reload this page.

PHP errors

The PHP version needs to be 5.2 or higher.

Your PHP version needs to be 5.2 or higher. Many server installations have version 5.1 but can be updated quite easily. Forums or knowledge base articles relating to your particular hosting server are a good place to look for instructions.

The PHP extension 'mysql' needs to be enabled/installed.

Your PHP installation needs to be installed and configured to work with mySQL. It's probably easiest to use a web server that is already set up with PHP, mySQL and Apache rather than installing them manually.

The PHP extension 'cURL' needs to be enabled/installed.
The PHP extension 'gd' needs to be enabled/installed.
The cURL and GD php extensions needs to be enabled/installed on your server.

Again, forums or knowledge base articles relating to your particular hosting server are a good place to look for instructions.

The PHP extension 'ionCube Loader' needs to be enabled/installed.

The ionCube Loader PHP extension needs to be installed. Full instructions and an installation helper script are available at the ionCube website. See the FAQs for reasons why this is extension is required.

Your PHP installation cannot send email using the mail() function.

Some installations of PHP aren't configured to work with 'sendmail' on your server, which means the php mail() function won't work. Please ensure your server has a Mail Transfer Agent installed and the php.ini 'sendmail_path' is correctly set up.